Быстрый старт

Данный раздел позволяет без подробного изучения всей документации начать работать в программе КОНГРАФ и включает в себя пример, в котором приводится описание основных действий по созданию, редактированию и компиляции проекта.

Для полного ознакомления с КОНГРАФ необходимо изучить остальные разделы справки.

Рассмотрим основные приемы работы в программе на примере разработки небольшого проекта регулятора температуры обратной воды калорифера в зависимости от температуры наружного воздуха для контроллера МС8 (тип проекта Контар).

Регулятор отслеживает температуры обратной воды и приточного воздуха. При выходе любой из этих температур из диапазона от +5 °C до +90 °C регулятор на цифровом выходе формирует флаг того, что температура вышла за допустимые пределы, который служит для перевода системы из рабочего режима в стояночный.

Структурная схема алгоритма проекта:


Пошаговое описание примера создания проекта в КОНГРАФ


Как открыть программу и как выйти из нее

  • Чтобы открыть программу, щелкните два раза на ярлыке , расположенном на рабочем столе, или выберите Пуск - Программы - Kontar - KONGRAF - KONGRAF
  • Чтобы изменить язык интерфейса с английского на русский, выберите команду меню View - Language - Russian.
  • Чтобы выйти из программы, выберите команду меню Файл - Выход (Ctrl+Q) или нажмите на значок , расположенный в правом верхнем углу окна программы. При этом будет задан вопрос о сохранении всех несохраненных файлов проекта.

Шаг 1 (создание структуры проекта)

  • Создание проекта
    Создайте главный блок проекта: Файл - Создать (Ctrl+N). В отрывшемся окне задайте Имя проекта "TBackWater". Не снимайте галочку "Автоматически разместить файл". Выберите тип "Контар".

  • Размещение блока контроллера MC8, выполняющего функцию Master
    Выберите в окне Библиотека (Библиотека функций - Приборные блоки - Контроллеры) и перетащите мышкой в окно главного блока проекта приборный блок "MC8 - Контроллер MC8". Задайте имя прибора "MC8-Master". Не снимайте галочку "Автоматически разместить файл". Выберите тип "Контроллер МС8".

  • Настройка свойств блока "MC8-Master"
    Нажмите правой кнопкой мыши на изображении блока "MC8", выберите из открывшегося контекстного меню команду Свойства. При этом откроется диалоговое окно свойств этого блока.

    На вкладке Блок задайте:

    • Комментарий - "MC8-Master";
    • Заголовок - "MC8-Master";
    • Тип - "MASTER";
    • Сетевой номер - "32".

    На вкладке Входы/Выходы установите:

    • для AI - Количество равным "2";
    • для AO - Количество равным "0";
    • для DI - Количество равным "1";
    • для DO - Количество равным "2".

    На вкладке Списки создайте два списка ("ПИД" и "Расписание"):

    • Нажмите кнопку и введите Имя - "ПИД", Комментарий - "Параметры ПИД-регулирования".
    • Нажмите кнопку (Добавить, Ctrl+A) и введите Имя - «Расписание», Комментарий - «Расписание температурного режима».

  • Размещение блока контроллера MC8, выполняющего функцию Slave
    Выберите в окне Библиотека (Библиотека функций - Приборные блоки - Контроллеры) и перетащите мышкой в окно главного блока проекта приборный блок "MC8 - Контроллер MC8". Задайте имя прибора «MC8-Slave». Не снимайте галочку "Автоматически разместить файл".
  • Настройка свойств блока "MС8-Slave"
    Нажмите правой кнопкой мыши на изображении блока "MC8", выберите из открывшегося контекстного меню команду Свойства. При этом откроется диалоговое окно свойств этого блока.

    На вкладке Блок задайте:

    • Комментарий - "MC8-Slave";
    • Заголовок - "MC8-Slave";
    • Тип - "SLAVE";
    • Сетевой номер - "1".

    На вкладке Входы/Выходы установите:

    • для AI - Количество равным "4";
    • для AO - Количество равным "2";
    • для DI - Количество равным "0";
    • для DO - Количество равным "1".

    На вкладке Списки создайте список Температуры:

    • Нажмите кнопку (Добавить, Ctrl+A) и введите Имя - «Температуры», Комментарий - «Температуры наруж. воздуха и обр. воды».

  • Сохраните проект: команда меню Файл - Сохранить (Ctrl+S).

Примечания:

  • Чтобы изменить размеры рабочего поля для размещения алгоблоков, выберите в главном меню команду Вид - Рабочая область и затем в открывшемся окне установите высоту и ширину поля:

  • Для удобства переключения между главным, приборными и комплексными алгоблоками, откройте вкладку Проект и выберите в списке нужный алгоблок для его открытия.


Шаг 2 (построение алгоритма работы контроллера MC8-Master)

  • Открытие блока "MC8-Master"
    Щелкните дважды левой кнопкой мыши на изображении блока "MC8-Master" или нажмите правой кнопкой мыши на изображении блока и выберите команду Открыть).
  • Размещение функциональных блоков внутри блока "MC8-Master"
    Далее из окна Библиотека перетащите в активное окно блока "MC8-Master" следующие функциональные блоки (ФБ), необходимые для реализации требуемого алгоритма:

    Библиотека функций - Функциональные блоки -

  • Создание связей внутри блока "MC8-Master"
    Проведите связи с помощью мышки между выводами алгоблоков согласно рисунку:

    Чтобы задать связь в виде линии:

    • Выберите соединяемый вывод одного алгоблока, нажав на нем левой кнопкой мыши, при этом должна начать рисоваться линия связи;
    • Ведите мышью линию связи до соединяемого вывода другого алгоблока, определяя нажатием на левую кнопку мыши ее излом, при этом удерживать кнопку нажатой не нужно;
    • Нажмите на конечном выводе левую кнопку мыши для завершения линии связи.
  • Cохраните проект: команда меню Файл - Сохранить (Ctrl+S).


Шаг 3 (построение алгоритма работы контроллера MC8-Slave)

  • Открытие блока "MC8-Slave"
    Щелкните дважды левой кнопкой мыши на изображении блока MC8-Slave или нажмите правой кнопкой мыши на изображении блока и выберите команду Открыть).
  • Размещение функциональных блоков внутри блока "MC8-Slave"
    Далее из окна Библиотека перетащите в активное окно блока MC8-Slave следующие функциональные блоки (ФБ), необходимые для реализации требуемого алгоритма:

    Библиотека функций - Функциональные блоки -

  • Настройка свойств комплексного блока (заголовок, задание количества входов и выходов, псевдонимы)
    Нажмите правой кнопкой мыши на изображении блока "КОМПЛЕКС", выберите в контекстном меню команду Свойства. При этом откроется диалоговое окно свойств этого блока.

    На вкладке Блок задайте:

    • Заголовок - "ОБР ВОДА".

    На вкладке Входы/Выходы задайте:

    • для AINP - Количество равным "2";
    • для DINP - Количество равным "0";
    • для AOUT - Количество равным "1";
    • для DOUT - Количество равным "1";
    • Для остальных входов и выходов оставьте без изменения.
    • для AINP[1] - Псевдоним "U1";
    • для AINP[2] - Псевдоним "U2";
    • для AOUT[1] - Псевдоним "T";
    • для DOUT[1] - Псевдоним "FAULT".

  • Создание связей внутри блока "MC8-Slave"
    Проведите связи с помощью мышки между выводами алгоблоков согласно рисунку:

    Чтобы задать связь в виде линии:

    • Выберите соединяемый вывод одного алгоблока, нажав на нем левой кнопкой мыши, при этом должна начать рисоваться линия связи;
    • Ведите мышью линию связи до соединяемого вывода другого алгоблока, определяя нажатием на левую кнопку мыши ее излом, при этом удерживать кнопку нажатой не нужно.
    • Нажмите на конечном выводе левую кнопку мыши для завершения линии связи.

    Чтобы задать связь в виде линка:

    • Выберите соединяемый вывод одного алгоблока и нажмите на нем правую кнопку мыши.

    • Выберите в открывшемся контекстном меню команду Линк.
    • Выберите соединяемый вывод другого алгоблока и нажмите на нем левую кнопку мыши.
    • После задания связи на конце соответствующих выводов появится зеленый маркер, а рядом - номер линка.

  • Открытие комплексного блока "ОБР ВОДА"
    Щелкните дважды левой кнопкой мыши на изображении блока "ОБР ВОДА" или нажмите правой кнопкой мыши на изображении блока и выберите команду Открыть.
  • Размещение функциональных блоков внутри комплексного блока "ОБР ВОДА"
    Далее из окна Библиотека в активное окно этого блока перетащите следующие ФБ, необходимые для реализации требуемого алгоритма:

    Библиотека функций - Функциональные блоки -

  • Создание связей внутри комплексного блока "ОБР ВОДА"
    Проведите связи с помощью мышки между выводами алгоблоков согласно рисунку:

  • Настройка свойств блока "КОМПАР ВЕРХ"
    Нажмите правой кнопкой мыши на изображении блока "КОМПАР ВЕРХ", выберите в контекстном меню команду Свойства. При этом откроется диалоговое окно свойств этого блока.
    На вкладке Параметры установите:
    • для XUP - Константа галочку, Значение равным "90";
    • для HYS - Константа галочку, Значение равным "30";

  • Настройка свойств блока "КОМПАР НИЖ"
    Нажмите правой кнопкой мыши на изображении блока "КОМПАР НИЖ", выберите в контекстном меню команду Свойства. При этом откроется диалоговое окно свойств этого блока.
    На вкладке Параметры установите:
    • для XLOW - Константа галочку, Значение равным "5";
    • для HYS - Константа галочку, Значение равным "30";
  • Настройка свойств блока "ФИЛЬТР"
    Нажмите правой кнопкой мыши на изображении блока "ФИЛЬТР" (входит в состав блока "ОБР ВОДА") выберите в контекстном меню команду Свойства. При этом откроется диалоговое окно свойств этого блока.
    На вкладке Параметры выберите:
    • TF и включите его в дополнительные список "ОБР ВОДА" с именем "Постоянная времени фильтра";
    • Y и включите его в дополнительные список "ОБР ВОДА" с именем "Температура".

  • Настройка свойств блока "ИЛИ"
    Нажмите правой кнопкой мыши на изображении блока "ИЛИ" (входит в состав блока "ОБР ВОДА"), выберите в контекстном меню команду Свойства. При этом откроется диалоговое окно свойств этого блока.
    На вкладке Параметры выберите Z и включите его в дополнительные список "ОБР ВОДА" с именем "Сигнализация тревоги".
  • Если после этого открыть вкладку Параметры в свойствах комплексного блока, то в ней появятся следующие параметры:

  • Размещение копии функционального блока "ОБР ВОДА" внутри блока "MC8-Slave"
    Щелкните правой кнопкой мыши на изображении блока "ОБР ВОДА". Выберите в контекстном меню команду Копировать. Щелкните правой кнопкой мыши в свободной точке рабочей области и выберите в контекстном меню команду Вставить.

    Введите Имя блока - "Наружный воздух":

    В свойствах созданного комплексного блока на вкладке Блок задайте: Заголовок - "НАРУЖ ВОЗД".

  • Создание дополнительных связей внутри блока "MC8-Slave"
    Проведите недостающие линии связи (задайте линки) между неподключенными выводами алгоблоков согласно рисунку:

  • Cохраните проект: команда меню Файл - Сохранить (Ctrl+S).

Шаг 4 (включение параметров в основные и дополнительные списки, назначения имен параметров и их начальных значений)

  • Настройка блока "ОБР ВОДА", расположенного внутри приборного блока "MC8-Slave"
    На вкладке Параметры в свойствах блока установите:
    • для параметра "Сигнализация тревоги":
      • Имя - "Т обр.воды недопустима";
      • Список тревог - галочку;
      • Список сессии - галочку.
    • для параметра "Температура":
      • Имя - "Т обр.воды";
      • Список - "Температуры";
      • Ед.измерения - "°С" (для ввода знака "°", удерживая клавишу Alt, нажмите "248" на цифровой клавиатуре);
      • Список симулятора - галочку;
      • Список сессии - галочку.
    • для параметра "Постоянная времени фильтра":
      • Константа - галочку;
      • Значение - "2".
  • Настройка блока "НАРУЖ ВОЗД", расположенного внутри приборного блока "MC8-Slave"
    На вкладке Параметры в свойствах блока установите:
    • для параметра "Сигнализация тревоги":
      • Имя - "Т воздх.недопустима";
      • Список тревог - галочку;
      • Список сессии - галочку.
    • для параметра "Температура":
      • Имя - "Т воздуха";
      • Список - "Температуры";
      • Ед.измерения - "°С";
      • Список симулятора - галочку;
      • Список сессии - галочку.
    • для параметра "Постоянная времени фильтра":
      • Константа - галочку;
      • Значение - "2".
  • Настройка блока "ПИД ИМП Р", расположенного внутри приборного блока "MC8-Master"
    На вкладке Параметры в свойствах блока установите:
    • для параметра TF:
      • Константа - галочку;
      • Значение - "0".
    • для параметра DZONE:
      • Имя - "Зона нечувств.";
      • Список - "ПИД";
      • Значение - "0,5";
      • Список симулятора - галочку.
    • для параметра KP:
      • Имя - "Коэф.пропорц.";
      • Список - "ПИД";
      • Значение - "2,5";
      • Список симулятора - галочку.
    • для параметра TI:
      • Имя - "Пост.врем.интегр.";
      • Список - "ПИД";
      • Значение - "300";
      • Список симулятора - галочку.
    • для параметра D:
      • Имя - "Коэф.диф.сост.";
      • Список - "ПИД";
      • Значение - "0";
      • Список симулятора - галочку.
    • для параметра TP:
      • Имя - "Длит.импульса";
      • Список - "ПИД";
      • Значение - "0,7";
      • Список симулятора - галочку.
    • для параметра B:
      • Имя - "Время люфта";
      • Список - "ПИД";
      • Значение - "0";
      • Список симулятора - галочку.
    • для параметров OPEN и CLOSE:
      • Константа - галочку.
  • Настройка блока "ГРАФ ОТОПЛ", расположенного внутри приборного блока "MC8-Master"
    На вкладке Параметры в свойствах блока установите:
    • для параметра X:
      • Имя - "Т воздуха";
      • Список - "Расписание";
      • Ед.измерения - "°C";
      • Список симулятора - галочку;
      • Список сессии - галочку.
    • для параметра Y:
      • Имя - "Т воды";
      • Список - "Расписание";
      • Ед.измерения - "°C";
      • Список симулятора - галочку;
      • Список сессии - галочку.
    • для параметра X1:
      • Имя - "Первая точка";
      • Список - "Расписание";
      • Ед.измерения - "°C";
      • Значение - "-26".
    • для параметра X2:
      • Имя - "Вторая точка";
      • Список - "Расписание";
      • Ед.измерения - "°C";
      • Значение - "8".
    • для параметра X0:
      • Имя - "Точка излома";
      • Список - "Расписание";
      • Ед.измерения - "°C";
      • Значение - "4".
    • для параметра Y1:
      • Имя - "Т воды в первой точке";
      • Список - "Расписание";
      • Ед.измерения - "°C";
      • Значение - "84".
    • для параметра Y2:
      • Имя - "Т воды во второй точке";
      • Список - "Расписание";
      • Ед.измерения - "°C";
      • Значение - "37".
    • для параметра Y0:
      • Имя - "Величина излома";
      • Список - "Расписание";
      • Ед.измерения - "°C";
      • Значение - "5".
  • Cохраните проект: команда меню Файл - Сохранить (Ctrl+S).

Шаг 5 (создание межприборных "виртуальных"(по сети RS485) соединений)

  • Нажмите правой кнопкой мыши на изображении блока "MC8-Master", выберите в контекстном меню команду Подключения вх/вых. В открывшемся окне установите:
    • AI.1 - "-НЕТ-";
    • AI.2 - "-НЕТ-".

  • Нажмите правой кнопкой мыши на изображении блока "MC8-Slave", выберите в контекстном меню команду Подключения вх/вых. В открывшемся окне установите:
    • AO.1 - "-НЕТ-";
    • AO.2 - "-НЕТ-".
  • Проведите связи:
    • между AO[1] (MC8-Slave) и AI[1] (MС8-Master);
    • между AO[2] (MC8-Slave) и AI[2] (MC8-Master).

  • Cохраните проект: команда меню Файл - Сохранить (Ctrl+S).

Шаг 6 (компиляция проекта)

  • Чтобы получить готовые к загрузке в приборы файлы функциональных алгоритмов, выберите команду меню Проект - Компилировать (Сtrl+T).

  • В случае отсутствия ошибок в проекте нажмите кнопку Продолжить. После компиляции файлы будут созданы и размещены в папке проекта: вложенных папках с именем "32" (для MC8-Master) и "1" (для MC8-Slave), в соответствии с серийными номерами приборов.