Симуляция

Симуляция - рекомендуемый этап разработки проекта, в процессе которого происходит обнаружение, локализация и устранение явных ошибок без использования приборов.

Во время симуляции на диаграммах строятся графики изменения выбранных параметров из списка симулятора. Анализ получаемых графических данных помогает сделать выводы о правильности выполнения алгоритма активного КФБ, приборного или главного блока.


Выбор параметров

Чтобы добавить параметр для симуляции, в окне свойств алгоблока на вкладке Параметры в разделе Включить в дополнительный список установите галочку напротив Список симулятора и задайте имя параметра.

Для поиска необходимого параметра (которые ранее были включены в какие-либо списки) можно воспользоваться окном Списки параметров (см. раздел Списки параметров).

В список симулятора можно также включить и параметры, которые не включены ни в один список.

Для просмотра всех параметров активного КФБ (приборного или главного блоков), добавленных в список симулятора, вызовите окно симулятора. Для этого, выберите команду Симулятор из меню Проект или нажмите кнопку на панели инструментов.

Параметры помечаются специальными маркерами. Красная стрелка вправо означает, что параметр является входным (могут быть изменены), синяя стрелка влево - выходным.


Настройка

Настройка симулятора заключается в создании необходимого количества диаграмм для вывода графиков и размещении на них параметров, требуемых для отображения в графическом виде. К настройке относится также установка параметров времени цикла, времени, даты и длительности процесса.

По умолчанию в окне симулятора содержится только одна диаграмма. В каждой такой диаграмме можно разместить неограниченное количество параметров. Для размещения параметра, выберите его из списка параметров и, удерживая на нем левую кнопку мыши, переместите на диаграмму. При этом внизу диаграммы появится имя этого параметра и цвет его будущего графика (выбирается автоматически).

Для создания новой диаграммы, нажмите кнопку на панели инструментов.

Окно диаграмм можно разбить также на страницы, на которых можно создать дополнительные диаграммы. Всего можно создать 5 страниц и на каждой не более 5 диаграмм.

Для создания новой страницы, нажмите кнопку на панели инструментов.

Чтобы перейти на другую страницу, щелкните на вкладку Страница с ее номером (внизу окна).

Для удаления ненужной диаграммы, щелкните на ней правой кнопкой мыши и выберите в отрывшемся контекстном меню команду Удалить - Диаграмму.

При удалении последней диаграммы с текущей страницы, данная страница удаляется, а номера страниц сдвигаются.

Для удаления ненужного параметра с выбранной диаграммы, щелкните на ней правой кнопкой мыши и выберите в отрывшемся контекстном меню команду Удалить - Графики и далее сам параметр.

Рядом с каждым параметром в левой части окна дано его текущее значение, которое дублируется также в строке состояния окна симулятора (при выделении параметра).

Для симуляции иногда бывает необходимо изменить значение какого-либо входного параметра, для этого щелкните на нем правой кнопкой мыши и выберите в контекстном меню команду Изменить значение параметра. Далее, в открывшемся диалоговом окне введите новое значение входного параметра. Изменение входных параметров можно делать и во время симуляции.

Чтобы изменить временнЫе параметры симуляции, выберите команду Параметры среды из меню Сервис. В открывшемся окне можно задать время цикла, время, дату и день недели.

Чтобы изменить длительность симуляции (по умолчанию задан непрерывный режим), выберите команду Время симуляции из меню Сервис. В открывшемся окне снимите галочку Не ограничено и установите в верхнем поле необходимую длительность, в сек.

Нужно учесть, что при закрытии окна симулятора, сделанные настройки не сохраняются. В любой момент можно снова развернуть окно основного интерфейса программы и продолжить редактирование проекта.


Просмотр результатов

Симуляция производится только для активного КФБ, приборного или главного блока, без участия остальных частей проекта.

Для запуска процесса симуляции нажмите кнопку на панели инструментов. Чтобы выполнить лишь один шаг, равный одному циклу, нажмите кнопку .

В процессе симуляции на диаграммах строятся графики параметров. Максимальное значение по временной шкале (оси абсцисс) равно 60 сек. Если время симуляции больше этого времени, то график начинает смещаться влево.

Для останова симуляции нажмите кнопку на панели инструментов.

Для продолжения симуляции снова нажмите кнопку .

Чтобы очистить все диаграммы, выберите команду Очистить диаграммы из меню Окно.


Привязка к сети контроллеров

Симулятор позволяет не только задавать входные параметры симулируемого блока (проекта) вручную, но и получать их из некоторой сети контроллеров по сети Ethernet. Результаты симуляции могут использоваться для задания значений входных (статических) параметров этой сети. Чтобы воспользоваться этой возможностью, необходимо в первую очередь соединиться с выбранной сетью контроллеров. Для этого откройте меню используется диалоговое окно, вызываемое пунктом меню Специальные - Подключение. При этом откроется следующее диалоговое окно:

В этом окне задается IP-адрес или доменное имя сети контроллеров, а также указывается пароль пользователя. При установке флажка Обновить сеть производится обновление состава сети в Master-контроллере (используется, если состав сети изменился).

Затем осуществляется привязка переменных симулироемого блока к переменным сети контроллеров. Для этого в контекстном меню параметра (вызывается нажатием правой кнопки мыши на имени параметра) выберите пункт Привязка. В открывшемся диалоговом окне можно задать источник значения для входного параметра симуляироемого блока и приемник для любого (входного или выходного) параметра.

Задание источника означает, что значение параметра будет считываться из привязанного параметра сети контроллеров. Задание приемника означает, что значение параметра будет записываться в привязанный параметр сети контроллеров. Приемником значения может служить только статическая переменная сети контроллеров. Кроме того, тип параметра симулируемого блока должен совпадать с типами как источника, так и приемника.

Чтобы задать источник значения для параметра, отметьте пункт Источник значения. Затем щелкните правой кнопкой мыши на поле ввода ниже. Появится контекстное меню, из которого можно выбрать параметр для привязки. Параметры сгруппированы в списки, а списки - в контроллеры. В контекстном меню содержатся только параметры, привязка которых к выбранной переменной допустима (совпадает тип).

Чтобы задать приемник значения для переменной, отметьте пункт Приемник значения. Затем щелкните правой кнопкой мыши на поле ввода ниже. Появится контекстное меню, из которого можно выбрать параметр для привязки. Параметры сгруппированы в списки, а списки - в контроллеры. В контекстном меню содержатся только параметры, привязка которых к выбранной переменной допустима (совпадает тип, и параметр является статическим).

Если при щелчке правой кнопкой мыши на поле ввода контекстное меню не появляется, возможно, Вы не подключились к сети котроллеров. Попробуйте подключиться еще раз, а затем повторите привязку.

Привязки можно сохранить в файл (*.simc). Для этого откройте меню Специальные - Сохранить конфигурацию. Чтобы восстановить сохраненные привязки, вначале подключитесь к сети контроллеров, как описано выше, а затем откройте меню Специальные - Загрузить конфигурацию. Если невозможно восстановить какую-либо привязку (отсутствует соответствующая переменная в симулируемом блоке (проекте) или связанный с ней параметр в подключенной сети), выводится соответствующее диагностическое сообщение.

Симуляция должна осуществляться в режиме реального времени (в диалоговом окне Сервис - Время симуляции выставлен флажок Неограниченное). При этом обмен данными с сетью контроллеров производится не чаще периода, заданного в пункте Цикл диалогового окна Сервис - Параметры среды. Время цикла увеличивается на время, затрачиваемое на обмен. Реальное время цикла отображается в левом нижнем углу окна симулятора.

При обмене могут возникать ошибки. При этом отображается диагностическое сообщение, и симуляция останавливается. При необходимости ее можно запустить повторно.