Главное меню основного интерфейса

Состав главного меню:
Файл, Правка, Вид, Блок, Проект, Окно, Справка.


Команды меню Файл

  • Создать - создание нового проекта.
  • Открыть – открытие проекта [тип файлов - Main block files (*.m.ab)] - или его алгоблока [тип файлов - Algoblock files (*.ab)].
  • Закрыть – закрытие окна активного алгоблока.
  • Закрыть все – закрытие проекта со всеми открытыми алгоблоками.
  • Сохранить – сохранение активного алгоблока.
  • Сохранить все – сохранение всех алгоблоков проекта.
  • Переименовать – переименование файла активного алгоблока.
  • Копировать проект - создание копии текущего проекта, открытие созданной копии проекта для редактирования.
  • Перезагрузить – загрузка последней сохраненной версии активного алгоблока.
  • Печать – вывод на печать.
  • Открыть в проводнике – содержит следующие команды:
    • Каталог проектов - открытие в проводнике каталога, в котором расположены проекты.
    • Каталог блоков пользователя - открытие в проводнике каталога, в котором расположены блоки пользователя.
  • Выход – выход из программы.


Команды меню Правка

  • Удалить - удаление выделенного (подсвечиваемого красным цветом) объекта или группы объектов.
  • Поиск – поиск текста в проекте с возможностью задания области поиска (прибор, список).
  • Параметры компилятора - изменение параметров компилятора.
  • Каталог проектов - выбор пути для каталога, в котором будут автоматически размещаться создаваемые проекты.
  • Каталог блоков пользователя - выбор пути для каталога, в котором будут размещаться блоки пользователя.


Команды меню Вид

  • Язык - выбор языка интерфейса (русский или английский).
  • Приблизить – увеличение масштаба изображения в 2 раза.
  • Отдалить – уменьшение масштаба изображения в 2 раза.
  • Рабочая область – задание размеров рабочей области (выбор ширины и высоты).
  • Показывать библиотеку – управление отображением окна Библиотека (и Проект).


Команды меню Блок

  • Свойства - редактирование или просмотр свойств активного алгоблока.
  • Подключения Вх/Вых - редактирование или просмотр “подключений” физических входов-выводов контроллера к входам-выводам соответствующего ему приборного блока.
  • Добавить в библиотеку - добавление активного комплексного блока в библиотеку (Блоки пользователя).


Команды меню Проект

  • Создать отладочные списки - Включить в алгоритм отладочный список _DEBUG.
  • Каталоги - выбор каталогов для включения вложенных в них алгоблоков в состав библиотеки.
  • Просмотр списков – просмотр всех списков проекта и принадлежащих этим спискам параметров.
  • Параметры BACnet... - просмотр списка созданных в проекте объектов BACnet (список параметров алгоблоков для сети BACnet). Команда доступна только для проектов, имеющих тип BACnet.
  • Компилировать – компиляция проекта.
  • Симулятор – симуляция активного блока.


Команды меню Окно

  • Каскадом - расположение всех открытых окон алгоблоков каскадом.
  • Сверху вниз - расположение всех открытых окон алгоблоков сверху вниз.
  • Слева направо - расположение всех открытых окон алгоблоков слева направо.
  • Свернуть все - сворачивание всех открытых окон алгоблоков.

Внизу, под разделительной чертой, расположен список всех открытых окон, позволяющий переключать их между собой (активное окно выделено галочкой).


Команды меню Справка

  • Справка – вызов справки.
  • О программе KONGRAF – просмотр краткой информации о программе.